华为switch上配置MSTP

拓扑:


配置思路

采用如下的思路配置MSTP的基本功能:


将SwitchA和SwitchC配置到一个域内,域名为RG1,创建实例1。


将SwitchB和SwitchD配置到另外一个域,域名为RG2,创建实例1。


配置交换机SwitchA为CIST总根。


在域RG1内,交换机SwitchA为CIST域根,SwitchA为实例1的域根。在SwitchA的GE1/0/2和GE1/0/1上应用根保护功能。


在域RG2内,交换机SwitchB为CIST域根,SwitchD为实例1的域根。


SwitchC和SwitchD的GE1/0/1与PC机相连,设置为边缘端口,同时在SwitchC和SwitchD上应用BPDU保护功能。


在SwitchA、SwitchB、SwitchC和SwitchD使用华为私有计算方法计算路径开销。




数据准备

为完成此配置例,需准备如下的数据:


SwitchA和SwitchC的域名为RG1


SwitchB和SwitchD的域名为RG2


各GE端口号如图1所示


VLAN号是1~20



操作步骤

配置交换机SwitchA

# 配置SwitchA的MST域。

<SwitchA> system-view  
[SwitchA] stp region-configuration  
[SwitchA-mst-region] region-name RG1  
[SwitchA-mst-region] instance 1 vlan 1 to 10

# 激活域配置。

[SwitchA-mst-region] active region-configuration  
[SwitchA-mst-region] quit

# 配置SwitchA在实例0中的优先级为0,保证SwitchA作为CIST的总根。

[SwitchA] stp instance 0 priority 0

# 配置SwitchA在实例1中的优先级为0,保证SwitchA作为实例1的域根。

[SwitchA] stp instance 1 priority 0

# 配置端口路径开销的计算方法为华为私有计算方法。

[SwitchA] stp pathcost-standard legacy

# 创建VLAN 2到20。

[SwitchA] vlan batch 2 to 20

# 将GE1/0/2加入VLAN。

[SwitchA] interface GigabitEthernet 1/0/2  
[SwitchA-GigabitEthernet1/0/2] port link-type trunk  
[SwitchA-GigabitEthernet1/0/2] port trunk allow-pass vlan 1 to 20  
[SwitchA-GigabitEthernet1/0/2] quit

# 将GE1/0/1加入VLAN。

[SwitchA] interface GigabitEthernet 1/0/1  
[SwitchA-GigabitEthernet1/0/1] port link-type trunk  
[SwitchA-GigabitEthernet1/0/1] port trunk allow-pass vlan 1 to 20  
[SwitchA-GigabitEthernet1/0/1] quit

# 在GE1/0/1上启动根保护。

[SwitchA] interface GigabitEthernet 1/0/1  
[SwitchA-GigabitEthernet1/0/1] stp root-protection  
[SwitchA-GigabitEthernet1/0/1] quit

# 在GE1/0/2上启动根保护。

[SwitchA] interface GigabitEthernet 1/0/2  
[SwitchA-GigabitEthernet1/0/2] stp root-protection  
[SwitchA-GigabitEthernet1/0/2] quit

# 启动MSTP。

[SwitchA] stp enable


配置交换机SwitchB

# 配置SwitchB的MST域。

[SwitchB] stp region-configuration  
[SwitchB-mst-region] region-name RG2    
[SwitchB-mst-region] instance 1 vlan 1 to 10

# 激活域配置。

[SwitchB-mst-region] active region-configuration  
[SwitchB-mst-region] quit

# 配置SwitchB在实例0中的优先级为4096,保证SwitchB作为CIST的域根。

[SwitchB] stp instance 0 priority 4096

# 配置端口路径的开销计算方法为华为私有计算方法。

[SwitchB] stp pathcost-standard legacy

# 创建VLAN 2到20。

[SwitchB] vlan batch 2 to 20

# 将GE1/0/1加入VLAN。

[SwitchB] interface GigabitEthernet 1/0/1  
[SwitchB-GigabitEthernet1/0/1] port link-type trunk  
[SwitchB-GigabitEthernet1/0/1] port trunk allow-pass vlan 1 to 20  
[SwitchB-GigabitEthernet1/0/1] quit

# 将GE1/0/2加入VLAN。

[SwitchB] interface GigabitEthernet 1/0/2  
[SwitchB-GigabitEthernet1/0/2] port link-type trunk  
[SwitchB-GigabitEthernet1/0/2] port trunk allow-pass vlan 1 to 20  
[SwitchB-GigabitEthernet1/0/2] quit

# 启动MSTP。

[SwitchB] stp enable


配置SwitchC

# 配置SwitchC的MST域。

[SwitchC] stp region-configuration  
[SwitchC-mst-region] region-name RG1  
[SwitchC-mst-region] instance 1 vlan 1 to 10

# 激活域配置。

[SwitchC-mst-region] active region-configuration  
[SwitchC-mst-region] quit

# 配置端口路径开销的计算方法为华为私有计算方法。

[SwitchC] stp pathcost-standard legacy

# 启动BPDU保护功能

[SwitchC] stp bpdu-protection

# 创建VLAN 2到20。

[SwitchC] vlan batch 2 to 20

# 将GE1/0/2加入VLAN。

[SwitchC] interface GigabitEthernet 1/0/2  
[SwitchC-GigabitEthernet1/0/2] port link-type trunk  
[SwitchC-GigabitEthernet1/0/2] port trunk allow-pass vlan 1 to 20  
[SwitchC-GigabitEthernet1/0/2] quit

# 将GE2/0/1加入VLAN。

[SwitchC] interface GigabitEthernet 2/0/1  
[SwitchC-GigabitEthernet2/0/1] port link-type trunk  
[SwitchC-GigabitEthernet2/0/1] port trunk allow-pass vlan 1 to 20 
[SwitchC-GigabitEthernet2/0/1] quit

# 将GE1/0/1配置成边缘端口。

[SwitchC] interface GigabitEthernet 1/0/1   
[SwitchC-GigabitEthernet1/0/1] stp edged-port enable 
 [SwitchC-GigabitEthernet1/0/1] port hybrid pvid vlan 20  
[SwitchC-GigabitEthernet1/0/1] port hybrid untagged vlan 20  
[SwitchC-GigabitEthernet1/0/1] quit

# 启动MSTP。

[SwitchC] stp enable


配置SwitchD

# 配置SwitchD的MST域。

[SwitchD] stp region-configuration  
[SwitchD-mst-region] region-name RG2  
[SwitchD-mst-region] instance 1 vlan 1 to 10

# 激活域配置。

[SwitchD-mst-region] active region-configuration  
[SwitchD-mst-region] quit

# 配置SwitchD在实例1中的优先级为0,保证SwitchD作为实例1的域根。

[SwitchD] stp instance 1 priority 0

# 配置端口路径开销的计算方法为华为私有计算方法。

[SwitchD] stp pathcost-standard legacy

# 启动BPDU保护功能。

[SwitchD] stp bpdu-protection

# 创建VLAN 2到20。

[SwitchD] vlan batch 2 to 20

# 将GE1/0/2加入VLAN。

[SwitchD] interface gigabitEthernet 1/0/2  
[SwitchD-GigabitEthernet1/0/2] port link-type trunk  
[SwitchD-GigabitEthernet1/0/2] port trunk allow-pass vlan 1 to 20  
[SwitchD-GigabitEthernet1/0/2] quit

# 将GE2/0/1加入VLAN。

[SwitchD] interface GigabitEthernet 2/0/1  
[SwitchD-GigabitEthernet2/0/1] port link-type trunk  
[SwitchD-GigabitEthernet2/0/1] port trunk allow-pass vlan 1 to 20  
[SwitchD-GigabitEthernet2/0/1] quit

# 将GE1/0/1配置成边缘端口。

[SwitchD] interface GigabitEthernet 1/0/1   
[SwitchD-GigabitEthernet1/0/1] stp edged-port enable  
[SwitchD-GigabitEthernet1/0/1] port hybrid pvid vlan 10  
[SwitchD-GigabitEthernet1/0/1] port hybrid untagged vlan 10  
[SwitchD-GigabitEthernet1/0/1] quit

# 启动MSTP。

[SwitchD] stp enable


验证配置结果

经过以上配置,在网络计算稳定后,执行以下操作,验证配置结果。

# 在SwitchA上执行display stp brief命令,查看端口状态和端口的保护类型,结果如下:

<SwitchA> display stp brief   MSTID      Port                  Role  STP State     Protection    
0        GigabitEthernet1/0/2  DESI  FORWARDING      ROOT     
0        GigabitEthernet1/0/1  DESI  FORWARDING      ROOT     
1        GigabitEthernet1/0/2  DESI  FORWARDING      ROOT     
1        GigabitEthernet1/0/1  DESI  FORWARDING      ROOT 

由于交换机SwitchA在CIST内优先级最高,所以SwitchA被选择为CIST总根,同时它也是RG1的域根。SwitchA的GE1/0/2和GE1/0/1在CIST上都是指定端口。

交换机SwitchA实例1上的优先级在域RG1内最高,所以SwitchA被选择为实例1的域根。GE1/0/2和GE1/0/1在实例1上都被计算为指定端口。

# 在SwitchC上执行display stp interface brief命令,结果如下:

<SwitchC> display stp interface GigabitEthernet 2/0/1 brief   
MSTID      Port                    Role  STP State     Protection     
0        GigabitEthernet2/0/1    ROOT  FORWARDING      NONE     
1        GigabitEthernet2/0/1    ROOT  FORWARDING      NONE  

<SwitchC> display stp interface GigabitEthernet 1/0/2 brief   
MSTID      Port                    Role  STP State     Protection     
0        GigabitEthernet1/0/2    DESI  FORWARDING      NONE     
1        GigabitEthernet1/0/2    DESI  FORWARDING      NONE

SwitchC的GE2/0/1在CIST和实例1中为根端口。SwitchC的另一个GE1/0/2,在CIST和实例1中都是指定端口。

# 在交换机SwitchB上执行display stp brief命令,结果如下:

<SwitchB> display stp brief   
MSTID      Port                  Role  STP State     Protection     
0        GigabitEthernet1/0/2  ROOT  FORWARDING      NONE     
0        GigabitEthernet1/0/1  DESI  FORWARDING      NONE     
1        GigabitEthernet1/0/2  MAST  FORWARDING      NONE     
1        GigabitEthernet1/0/1  ROOT  FORWARDING      NONE

交换机SwitchB在CIST上的优先级低于SwitchA,GE1/0/2在CIST被计算为根端口。同时因为SwitchA和SwitchB不属于同一个域,所以GE1/0/2在实例1上被计算为Master端口。在实例1中,SwitchB的优先级低于SwitchD,所以GE1/0/1被计算为根端口。SwitchB在CIST中的优先级高于SwitchD,GE1/0/1在CIST被计算为指定端口。

# 在SwitchD上执行display stp interface brief命令,结果如下:

<SwitchD> display stp interface GigabitEthernet 2/0/1 brief   
MSTID      Port                    Role  STP State     Protection     
0        GigabitEthernet2/0/1    ROOT  FORWARDING      NONE     
1        GigabitEthernet2/0/1    DESI  FORWARDING      NONE  

<SwitchD> display stp interface GigabitEthernet 1/0/2 brief   
MSTID      Port                    Role  STP State     Protection     
0        GigabitEthernet1/0/2    ALTE  DISCARDING      NONE     
1        GigabitEthernet1/0/2    ALTE  DISCARDING      NONE

因为SwitchD的GE1/0/2在CIST上为Alternate端口,又因为SwitchD与SwitchC不在同一个域,所以GE1/0/2在实例1中的也被选择为Alternate端口。

GE2/0/1在CIST为根端口,因为SwitchD在实例1中的优先级比SwitchB高,所以GE2/0/1在实例1上被作为指定端口。


已标记关键词 清除标记
©️2020 CSDN 皮肤主题: 大白 设计师:CSDN官方博客 返回首页