路由器mstp多域配置举例

MSTP全称为Multiple Spanning TreeProtocol,它兼容STP和RSTP,并弥补了STP和RSTP的缺陷。MSTP 既能快速收敛,也能使不同VLAN 流量沿各自的路径分发,从而为冗余链路提供良好的负载分担机制。下面给出一个路由器MSTP实例配置:

一 网络拓扑


二 网络规划

  1 将路由器A和C配置到一个域内,域名为RG1,创建实例1; 
     2 将路由器B和D配置到另一个域,域名为RG2,创建实例1; 
     3 配置路由器A为CIST 总根; 
     4 在域RG1内,路由器A为CIST域根,路由器A为实例1的域根。在路由器A的GE 端口1/0/1 和GE 端口1/0/0 上应 用根保护功能; 
     5 在域RG2内,路由器B为CIST域根,路由器D为实例1的域根; 
     6 路由器C和D的GE端口1/0/0与PC相连,设置为边缘端口,同时在路由器C和D上应用BPDU 保护功能; 
     7 在路由器A、B、C 和D使用华为私有计算方法计算路径开销。

三 路由器配置 

1 路由器A配置 

配置路由器A的MST域 
<RouterA> system-view 
[RouterA] stp region-configuration 
[RouterA-mst-region] region-name RG1 
[RouterA-mst-region] instance 1 vlan 1  to 10 

激活域配置 
[RouterA-mst-region] active region-configuration 
[RouterA-mst-region] quit 

配置路由器A在实例0中的优先级为0,保证路由器A为CIST的总根 
[RouterA] stp instance 0 priority 0 

配置RouterA在实例1 中的优先级为0,保证RouterA 作为实例1 的域根 
[RouterA] stp instance 1 priority 0 

配置端口路径开销的计算方法为华为私有计算方法 
[RouterA] stp pathcost-standard legacy 

创建VLAN 1 到20。 
[RouterA] vlan batch 1 to 20 

将端口1/0/1 加入VLAN 
[RouterA] interface GigabitEthernet 1/0/1 
[RouterA-GigabitEthernet1/0/1] portswitch 
[RouterA-GigabitEthernet1/0/1] port trunk allow-pass vlan 1 to 20 
[RouterA-GigabitEthernet1/0/1] quit 

将端口1/0/0 加入VLAN 
[RouterA] interface GigabitEthernet 1/0/0 
[RouterA-GigabitEthernet1/0/0] portswitch 
[RouterA-GigabitEthernet1/0/0] port trunk allow-pass vlan 1 to 20 
[RouterA-GigabitEthernet1/0/0] quit 

在端口1/0/1上启动根保护 
[RouterA] interface GigabitEthernet 1/0/1 [RouterA-GigabitEthernet1/0/1] stp root-protection 
[RouterA-GigabitEthernet1/0/1] quit 


在端口1/0/0上启动根保护 
[RouterA] interface GigabitEthernet 1/0/0 [RouterA-GigabitEthernet1/0/0] stp root-protection 
[RouterA-GigabitEthernet1/0/0] quit 

启动MSTP [RouterA] stp enable 

2 路由器B配置 


配置RouterB 的MST 域 [RouterB] stp region-configuration 
[RouterB-mst-region] region-name RG2 
[RouterB-mst-region] instance 1 vlan 1 to 10 

激活域配置 
[RouterB-mst-region] active region-configuration 
[RouterB-mst-region] quit 

配置RouterB 在实例0 中的优先级为4096,保证RouterB作为CIST的域根 
[RouterB] stp instance 0 priority 4096 

配置端口路径的开销计算方法为华为私有计算方法 
[RouterB] stp pathcost-standard legacy 

创建VLAN 1到20 
[RouterB] vlan batch 1 to 20 

将端口1/0/0加入VLAN 
[RouterB] interface GigabitEthernet 1/0/0 
[RouterB-GigabitEthernet1/0/0] portswitch 
[RouterB-GigabitEthernet1/0/0] port trunk allow-pass vlan 1 to 20 
[RouterB-GigabitEthernet1/0/0] quit 

将端口1/0/1加入VLAN 
[RouterB] interface GigabitEthernet 1/0/1
[RouterB-GigabitEthernet1/0/1] portswitch 
[RouterB-GigabitEthernet1/0/1] port trunk allow-pass vlan 1 to 20 
[RouterB-GigabitEthernet1/0/1] quit 

启动MSTP [RouterB] stp enable 

3 路由器C配置 


配置RouterC 的MST域 
[RouterC] stp region-configuration 
[RouterC-mst-region] region-name RG1 
[RouterC-mst-region] instance 1 vlan 1 to 10 

激活域配置 
[RouterC-mst-region] active region-configuration 
[RouterC-mst-region] quit 

配置端口路径开销的计算方法为华为私有计算方法 
[RouterC] stp pathcost-standard legacy 

启动BPDU 保护功能 
[RouterC] stp bpdu-protection 

创建VLAN1到20 
[RouterC] vlan batch 1 to 20 

将端口1/0/1加入VLAN 
[RouterC] interface GigabitEthernet 1/0/1 
[RouterC-GigabitEthernet1/0/1] portswitch 
[RouterC-GigabitEthernet1/0/1] port link-type hybrid 
[RouterC-GigabitEthernet1/0/1] port trunk allow-pass vlan 1 to 20 
[RouterC-GigabitEthernet1/0/1] quit 

将端口2/0/0加入VLAN 
[RouterC] interface GigabitEthernet 2/0/0 
[RouterC-GigabitEthernet2/0/0] portswitch 
[RouterC-GigabitEthernet2/0/0] port link-type hybrid 
[RouterC-GigabitEthernet2/0/0] port trunk allow-pass vlan 1 to 20 
[RouterC-GigabitEthernet2/0/0] quit 


将端口1/0/0配置成边缘端口 
[RouterC] interface GigabitEthernet 1/0/0 
[RouterC-GigabitEthernet1/0/0] portswitch 
[RouterC-GigabitEthernet1/0/0] stp edged-port enable 
[RouterC-GigabitEthernet1/0/0] quit 

启动MSTP 
[RouterC] stp enable 

4 路由器D配置 


配置RouterD的MST域 
[RouterD] stp region-configuration 
[RouterD-mst-region] region-name RG2 
[RouterD-mst-region] instance 1 vlan 1 to 10 

激活域配置 
[RouterD-mst-region] active region-configuration 
[RouterD-mst-region] quit 

配置RouterD在实例1中的优先级为0,保证RouterD做为实例1的域根 
[RouterD] stp instance 1 priority 0 

配置端口路径开销的计算方法为华为私有计算方法 
[RouterD] stp pathcost-standard legacy 

启动BPDU 保护功能 
[RouterD] stp bpdu-protection 

创建VLAN 1到20 
[RouterD] vlan batch 1 to 20 

将端口1/0/1加入VLAN 
[RouterD] interface gigabitEthernet 1/0/1 
[RouterD-GigabitEthernet1/0/1] portswitch 
[RouterD-GigabitEthernet1/0/1] port link-type hybrid [RouterD-GigabitEthernet1/0/1] port trunk allow-pass vlan 1 to 20 
[RouterD-GigabitEthernet1/0/2] quit

将端口2/0/0 加入VLAN 
[RouterD] interface GigabitEthernet 2/0/0 
[RouterD-GigabitEthernet2/0/0] portswitch 
[RouterD-GigabitEthernet2/0/0] port link-type hybrid [RouterD-GigabitEthernet2/0/0] port trunk allow-pass vlan 1 to 20 
[RouterD-GigabitEthernet2/0/0] quit 

将端口1/0/0 配置成边缘端口。 
[RouterD] interface GigabitEthernet 1/0/0 
[RouterD-GigabitEthernet1/0/0] portswitch 
[RouterD-GigabitEthernet1/0/0] stp edged-port enable 
[RouterD-GigabitEthernet1/0/0] quit 

启动MSTP 
[RouterD] stp enable 

四 验证结果 



路由器A、B、C和D经过上述配置,待网络状态稳定后,执行以下操作,验证配置结果。 

1 在路由器A上

执行display stp brief 命令,查看端口状态和保护类型,结果如下: 
<RouterA> display stp brief 
MSTID Port Role STP State Protection 
0 GigabitEthernet1/0/1 DESI FORWARDING ROOT 
0 GigabitEthernet1/0/0 DESI FORWARDING ROOT 
1 GigabitEthernet1/0/1 DESI FORWARDING ROOT 
1 GigabitEthernet1/0/0 DESI FORWARDING ROOT 


由于路由器A在CIST内优先级最高,所以其被选择为CIST 总根,同时也是RG1 的域根。路由器的端口1/0/1 和 1/0/0在CIST 上均为指定端口。路由器A实例1上的优先级在域RG1内最高,所以路由器A被选择为实例1的域根。端 口1/0/1和1/0/0在实例1上都被计算为指定端口。 


2 在路由器C上


执行display stp interface brief 命令,结果如下: 
<RouterC> display stp interface GigabitEthernet 2/0/0 brief 
MSTID Port Role STP State Protection 
0 GigabitEthernet2/0/0 ROOT FORWARDING NONE 
1 GigabitEthernet2/0/0 ROOT FORWARDING NONE 
<RouterC> display stp interface GigabitEthernet 1/0/1 brief 
MSTID Port Role STP State Protection 
0 GigabitEthernet1/0/1 DESI FORWARDING NONE 
1 GigabitEthernet1/0/1 DESI FORWARDING NONE 


路由器C的端口2/0/0在CIST和实例1中为根端口,而另一端口1/0/1,在CIST和实例1中均为指定端口。 

3 在路由器RouterB上


执行display stp brief 命令,结果如下: 
<RouterB> display stp brief 
MSTID Port Role STP State Protection 
0 GigabitEthernet1/0/0 ROOT FORWARDING NONE 
0 GigabitEthernet1/0/1 DESI FORWARDING NONE 
1 GigabitEthernet1/0/0 MAST FORWARDING NONE 
1 GigabitEthernet1/0/1 ROOT FORWARDING NONE 


路由器B在CIST上的优先级低于RouterA,端口1/0/0 在CIST 被计算为根端口。同时因为路由器A和B不属于同一个 域,所以端口1/0/0在实例1上被计算为Master 端口。在实例1 中,路由器B的优先级低于RouterD,所以端口 1/0/1 被计算为根端口,同时在CIST 中的优先高于路由器D,端口1/0/1在CIST 被计算为指定端口。 


4 在RouterD 上



执行display stp interface brief 命令,结果如下: 


<RouterD> display stp interface GigabitEthernet 2/0/0 brief 
MSTID Port Role STP State Protection 
0 GigabitEthernet2/0/0 ROOT FORWARDING NONE 
1 GigabitEthernet2/0/0 DESI FORWARDING NONE 
<RouterD> display stp interface GigabitEthernet 1/0/1 brief 
MSTID Port Role STP State Protection 
0 GigabitEthernet1/0/1 ALTE DISCARDING NONE 
1 GigabitEthernet1/0/1 ALTE DISCARDING NONE 


因为路由器D的端口1/0/1在CIST 上为Alternate 端口,又因为路由器D与C不在同一个域,所以端口1/0/1在实例 1中的也被选择为Alternate 端口。端口2/0/0在CIST为根端口,因
为路由器D在实例1中的优先级高,所以端口 2/0/0在实例1上被作为指定端口。

转载自花脸猴博客:http://www.hualianhou.com/post/186.html

已标记关键词 清除标记
©️2020 CSDN 皮肤主题: 大白 设计师:CSDN官方博客 返回首页